ВПР в excel, подробная инструкция по использованию


+1 голос
Нужно объединить несколько таблиц в одну, как я понял для этого и создана функция ВПР в Excel. Но использовать ее так и не получилось - желаемый результат не получается. Покажите, пожалуйста, на примере как ей пользоваться.
спросил 12 февраля Семен в категории IT технологии

1 Ответ

0 +/-
Лучший ответ

В Excel множество замечательных и удобных функций и возможностей. Сегодня мы поговорим о функции ВПР (в английской версии Excel она называется VLOOKUP).

Для чего нужна функция ВПР в Excel

Допустим, у вас есть две таблицы с ценами на запчасти, первая за 2015 год, вторая за 2016. Вы хотите сравнить цены каждой запчасти по прошествии года.

Таблица с ценами 2015 года:

Сравнение данных в Excel

Таблица с ценами 2016 года:

Сравнение данных в Excel

Казалось бы, что сложного в этой задаче – просто упорядочим обе таблицы по имени запчасти и скопируем данные из одной таблицы в другую. Но проблема в том в 2016 году появились новые запчасти и данные просто не совпадут. Может появиться желание вручную перенести данные. В данном примере это легко выполнимо, а представьте, что таких строк у вас не 10, а 10 000, к примеру. Именно для решения таких задач функция ВПР подходит просто идеально.

Как использовать функцию ВПР в Excel

Скорее всего, ваши таблицы будут в разных файлах. Для удобства, скопируйте их на разные листы одной книги, как в примере выше. Нам нужно чтобы в таблице 2016 года в третьем столбце появились данные из 2015 года. Выбираем ячейку С2 и пишем «=ВПР(» без кавычек, Excel сразу выведет подсказку:

Подсказки Excel

Рассмотрим синтаксис команды «ВПР(искомое_значение, таблица, номер_столбца, [интервальный_просмотр])» подробнее.

Искомое значение – значения, которые мы будем искать в другой таблица, в нашем случае это ячейки А2-А10.

Искомое значение функции ВПР

Таблица – часть второй таблицы (в нашем случае 2015 года) где мы будем искать искомые значения. В нашем случае переходим на вкладку 2015 и выделяем столбцы A и B.

Выбор данных для поиска ВПР

Номер столбца – столбец из которого будут подставляться данные, в нашем случае это «2».

Интервальный просмотр – искать точное совпадение или примерное. Нам нужно точное, поэтому указываем «ЛОЖЬ».

Итого, конечная формула получается такая: «=ВПР(A2;'2015'!A:B;2;ЛОЖЬ)». То есть, еще раз, как работает формула на конкретном примере: берется слово МОТОР из таблицы 2015 и ищется в таблице 2016, после чего берется число 1000 из второго столбца и подставляется в таблицу 2016. 

Остается только растянуть формулу на всю длину столбца, ну и в нашем случае добавить столбец с разницей. 

Результат работы ВПР

У двух значений написано #Н/Д – это значит «Нет данных», это как раз те позиции, которых не было в 2015 году.

Вот и все! Если будут вопросы – пишите! Удачи!

 

ответил 12 февраля Эксперт Илья (6,261 баллов)
выбран 18 февраля Эксперт Дмитрий