ВПР в excel, подробная инструкция по использованию


5
Нужно объединить несколько таблиц в одну, как я понял для этого и создана функция ВПР в Excel. Но использовать ее так и не получилось - желаемый результат не получается. Покажите, пожалуйста, на примере как ей пользоваться.
спросил 12 февраля 2016 Семен в категории IT технологии
1 Ответ
0
Лучший ответ

В Excel множество замечательных и удобных функций и возможностей. Сегодня мы поговорим о функции ВПР (в английской версии Excel она называется VLOOKUP).

Для чего нужна функция ВПР в Excel
Автор считает, что эти материалы могут вам помочь:
  • Как удалить строку в excel - подробная инструкция
  • Сумма в excel, подробная инструкция
  • Графика с помощью ВПР
  • Выпадающий список в Excel, подробная инструкция
  • Допустим, у вас есть две таблицы с ценами на запчасти, первая за 2015 год, вторая за 2016. Вы хотите сравнить цены каждой запчасти по прошествии года.

    Таблица с ценами 2015 года:

    Сравнение данных в Excel

    Таблица с ценами 2016 года:

    Сравнение данных в Excel

    Казалось бы, что сложного в этой задаче – просто упорядочим обе таблицы по имени запчасти и скопируем данные из одной таблицы в другую. Но проблема в том в 2016 году появились новые запчасти и данные просто не совпадут. Может появиться желание вручную перенести данные. В данном примере это легко выполнимо, а представьте, что таких строк у вас не 10, а 10 000, к примеру. Именно для решения таких задач функция ВПР подходит просто идеально.

    Как использовать функцию ВПР в Excel

    Скорее всего, ваши таблицы будут в разных файлах. Для удобства, скопируйте их на разные листы одной книги, как в примере выше. Нам нужно чтобы в таблице 2016 года в третьем столбце появились данные из 2015 года. Выбираем ячейку С2 и пишем «=ВПР(» без кавычек, Excel сразу выведет подсказку:

    Подсказки Excel

    Рассмотрим синтаксис команды «ВПР(искомое_значение, таблица, номер_столбца, [интервальный_просмотр])» подробнее.

    Искомое значение – значения, которые мы будем искать в другой таблица, в нашем случае это ячейки А2-А10.

    Искомое значение функции ВПР

    Таблица – часть второй таблицы (в нашем случае 2015 года) где мы будем искать искомые значения. В нашем случае переходим на вкладку 2015 и выделяем столбцы A и B.

    Выбор данных для поиска ВПР

    Номер столбца – столбец из которого будут подставляться данные, в нашем случае это «2».

    Интервальный просмотр – искать точное совпадение или примерное. Нам нужно точное, поэтому указываем «ЛОЖЬ».

    Итого, конечная формула получается такая: «=ВПР(A2;'2015'!A:B;2;ЛОЖЬ)». То есть, еще раз, как работает формула на конкретном примере: берется слово МОТОР из таблицы 2015 и ищется в таблице 2016, после чего берется число 1000 из второго столбца и подставляется в таблицу 2016. 

    Остается только растянуть формулу на всю длину столбца, ну и в нашем случае добавить столбец с разницей. 

    Результат работы ВПР

    У двух значений написано #Н/Д – это значит «Нет данных», это как раз те позиции, которых не было в 2015 году.

    Вот и все! Если будут вопросы – пишите! Удачи!

    Помогите автору статьи:
    вКонтакте
    Одноклассники
    Мой Мир
    Google+
    Каждый раз, когда вы делитесь этой статьей в социальной сети, ее автор становится немного счастливее! Пожалуйста нажмите на одну из кнопок выше!
    Это будет полезно для вас:
  • Формулы в Excel, инструкция по использованию
  • Условное форматирование в Excel - что это и как этим пользоваться
  • Из PDF в Excel - инструкция по конвертации
  • Защита документов, инструкция с картинками
  • Xlsx в xls – подробная инструкция по конвертации
  • Сортировка в Excel, инструкция с картинками
  • Разные колонтитулы на разных страницах в Word - подробная инструкция
  • Замена в Ворде, подробная инструкция
  • ответил 12 февраля 2016 Эксперт Илья (15,809 баллов)
    выбран 18 февраля 2016 Эксперт Дмитрий
    Просто и исчерпывающе! Благодарю за пример!))
    Я рад, что статья оказалась полезна для вас!
    Новые статьи:
  • Калифорнийская сияющая кошка: описание, фото, характер
  • Можно ли пить минеральную воду – дозировка и особенности
  • Гималайская кошка – описание породы, характер, фото
  • «Смарт для своих» - описание тарифа МТС в 2018 году
  • Как поставить кавычки «Ёлочки» в Word и браузере - все способы
  • Как полностью удалить DriverPack Solution или Cloud
  • Что за файл run.hta в папке bin\Tools и как убрать окно
  • Приложению заблокирован доступ к графическому оборудованию - как исправить
  • Котлеты из фарша без хлеба - мой проверенный вкусный рецепт
  • Что за ошибка «Прекращена работа Java TM Platform SE binary»?
  • Failed to initialize authentication interface exiting - что делать?
  • Как отключить Secure Boot в Bios HP - инструкция
  • Жесткий диск издает звуки — расшифровка
  • Артефакты при загрузке Windows и Bios — устранение проблемы
  • Failed to initialize BattlEye Service driver load error 1450 - что за ошибка?
  • Как отключить UEFI Secure Boot в Asus - инструкция